Business Cloud would like to inform you that the maintenance of our API server in the Athens cloud location has been completed.
There was no impact on existing/running customers’ virtual machines, hosts, network accessibility, or any other running services. API functionality and the web interface are now operating normally.
Posted Sep 08, 2026 - 14:33 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2026 - 13:00 UTC
Scheduled
Business Cloud would like to inform you that we are going to perform a maintenance of our API server in the Athens cloud location.
There will be no impact on already existing/running customers’ virtual machines, hosts, network accessibility and/or any other running services.
During the maintenance, customers will not be able to perform any calls to the API, directly or through the web interface, for about 5 minutes. A brief interruption of the web interface may also occur.
Posted Sep 08, 2026 - 12:49 UTC
This scheduled maintenance affected: Athens Cloud.